RequestsDependencyWarning: urllib3 (xxx) or chardet (xxx) doesn’t match a supported version!

363次阅读

解决办法:

sudo pip install –upgrade urllib3

sudo pip install –upgrade requests

根本原因是:

requests本身自带urllib3这个库的副本,在这个库的子目录下;

解决方案就是要么升级库,或者重新安装现有的版本,可以强制安装:
pip install –force-reinstall requests==xx.xx
或者升级:
pip install –upgrade requests

正文完